Who can show me a successefully-running Pressbooks & Moodle configuration page screenshot?

I installed Pressbooks LTI plugin, My Pressbooks&Pressbooks LTI provider and Moodle are both the latest stable version.

I need enable Content Selection feature, preferrably LTI 1.3.

I tried almost every possible configuration matching of the both sides. In Moodle side, it still shows: An error occurred when launching the external tool:Sorry, there was an error connecting you to the application.

Hi @fishfree, our LTI provider plugin was written to be complaint with the LTI 1.1 specification – we have not yet updated it to conform to the new 1.3 specification. You may want to consult our documentation: https://docs.pressbooks.org/integrations/lti/ and https://github.com/pressbooks/pressbooks-lti-provider#moodle. If that doesn’t help, I think @beckej has some experience with open source Pressbooks-Moodle integrations?

1 Like

Hi FishFree:

I have to be honest. I know that the Content Selection feature is part of the LTI Specification, but I have never found it very useful.

For the content selector to work well, you have to make a connection to a book, and then from the content selector, you can choose the chapters and parts that you want to select. What this means, to my understanding, is that every book would need to be set up as a separate LTI tool with the format https://site/book/format/lti

Most LMS admins I know, would much rather create the connection to the Network of books, not to individual books. I find it more convenient to export the entire book from Pressbooks as a 1.1 book, and then from the Moodle import page select the chapters that I want displayed.

While I can’t help you with the content selector tool, I would be very happy to help you troubleshoot the 1.1 connection.

1 Like

Just tested in Moodle 3.4.X using the Add tool feature, looks like this:

As others has noted:

In Pressbooks:

  • Add your Moodle domain to the LTI2 Registration Whitelist
  • If the user’s web browser does not allow 3rd Party Cookies, then logins will not work when Pressbooks is in an iframe.
  • If the web server has incorrect X-Frame-Options settings, then iframes will refuse to display. More info.

Thank you all! Now I change to the LTI 1.1 in both sides. It seems progressing. But when I click the “Select content” in Moodle, it shows up an error as below:

@dac.chartrand Could you please show your complete configuration(expanding all config sections on that pge) of your Pressbooks external tool in Moodle?

Hi FishFree,

If you are using the 1.1 LTI option, (which I think is the way to go and the most popular) you should not use the select content button.

  1. First, just doublecheck your setting from Moodle: In this example below, I have selected to not show the tool to the faculty members. Since we will always be importing from Pressbooks. This is just to avoid them trying to use the content selection tool.

  2. Next, go to your pressbooks server, and export the book you want as an 1.1 LTI package. The package that you download will include a link to each Pressbooks chapters (Or whatever chapters you have selected to export from the organize screen)

  3. Next import that package into Moodle using the Moodle “Restore” Features.

@beckej Thank you! But I cannot use the course Restore feature to import the Pressbooks-exported “Common Cartridge 1.1 (LTI Links)” file. Instead, I add a resource of “IMS content package” and upload the file. And the Table of Content shows up normally in Moodle, but no clickable LTI links to the detail pages.

@fishfree

I’m confused why you said you “cannot use the course restore feature.”

Has your administrator disabled it?

The package you have downloaded from Pressbooks is a Moodle backup file in the IMS Common Cartridge format. This file type is made to be used using the course restore features and not the same as the IMS “content package”. It won’t work the way you were uploading it.

You should be able to click on Restore from the admin menu, and upload your backup file.

After loading the backup file, Moodle will recognize that it is a course backup in the IMS 1.1 format.

You will then be asked if you want to import into the current course, which you should.

2 Likes

My screenshot:

Important concepts to understand:

  • This was automatically configured using LTI 2.0 (This is supported by Moodle, I clicked Next, Next, Next… everything was done for me automatically)
  • Configuration is per book (Uses a book URL.)

Most people use LTI 1.1, configure manually, and use Common Cartridge to mass import. It’s more convenient than using a per book config to get to a menu that lets you select 1 chapter at a time. Furthermore, LTI 2.0 is deprecated. The next version is LTI 1.3, is coming soon but is currently not supported. Someone else can probably explain this confusing version numbering better than I.

2 Likes

On LTI versioning, see: https://www.imsglobal.org/lti-adoption-roadmap. TL;DR is that the accepted LTI was 1.1. IMS Global released 1.2 (simpler) and 2.0 (more complicated) as replacements for 1.1, but they didn’t work very well and weren’t adopted much (most people stuck with 1.1). IMS Global scrapped 1.2 & 2.0 and rebuilt a better implementation to succeed 1.1 and released that as 1.3. They’re now saying 1.3 is the way to go for everyone. The recommended adoption path is now 1.1 -> 1.3. Our current plugin supports 1.1 and elements of 2.0 – we plan to update our plugin to support the newish 1.3 spec sometime soon, as Dac said.

1 Like

Finally, it turned out that the error is caused by the pressbooks-cas-sso plugins enabled in my Pressbooks. After disabling it, the Content-selection features plays perfectly with LTI 1.1.
Thank you all!

Edit: Today, I re-enable the pressbooks-cas-sso plugin, the LTI still works. Very confusing. Anyway, all works now!

Thank you very much! I tried this method. It also works!

1 Like

Thank you very much! It works!

1 Like