URL Import Critical Error


When I try to import another Pressbook’s material via URL, I can’t even get to the page where you select which section of the original book to import. I simply get a message that there has been a critical error on the website, and the linked help page doesn’t seem to have relevant suggestions. Just yesterday, this import tool was working, but today it isn’t; any ideas how to fix this or what the problem might be? Everything else on the site seems to be working fine.

Hi @Jacob_Algrim, sorry to hear. I’m unsure what would cause this error and I’m trying to replicate it. So far importing via URL is working on my end, but which Pressbooks network are you on and which book are you aiming to import material from?

Hi @ThomasWeideman , thanks for your quick response. Our network is pressbooks-dev.oer.hawaii.edu

The book we are trying to import from is https://pressbooks-dev.oer.hawaii.edu/anatomyandphysiology2021/

The instance we are trying to import into is a clone of the above book that an instructor is adapting for her own context. We assume the glossary didn’t come over when originally cloned because the CM Tooltip plugin was not activated on the receiving instance. The import tool appeared to be working fine yesterday, but today after I activated the Tooltip plugin it was no longer working (not sure if these are connected).

I have tried importing other books into other instances and I get the same error message, so it doesn’t seem to be a problem limited to just those books linked above. An IT person on our end reverted the CM Tooltip plugin to a previous version thinking that the plugin may be the issue, but I still get the same error message regardless of what I am trying to import into where.

Since it isn’t a network I have support / admin access to I’m not sure, but for what it’s worth I haven’t heard the same import error reported on other networks. I’m not familiar with the CM Tooltip plugin but are you able to import while the plugin is deactivated at the book or network level? If there were any other recent changes to plugins on the network, this may be worth checking.