"This page does not exist" error with LTI plugin


#1

We’ve just installed an LTI plugin based on the one Lumen Learning has been using for some time on our production site. While it works just fine on our dev server, on our production instance, we’re getting a “Sorry, but this page does not exist.” when we try to view the published LTI page. See: https://wisc.pb.unizin.org/blog/lti_consumer/uw-madison-canvas-production/ [production] vs. https://wisc-dev.pb.unizin.org/blog/lti_consumer/for-canvas-testing/ [dev] Has anyone else seen this before and/or have any idea how to resolve it? @ned, without asking you to become aware of or support a third-party tool that you didn’t write, are you aware of any recent PB code updates that might suppress a ‘blog’ page published in the way that the LTI consumer tool (https://github.com/lumenlearning/lti) appears to publish them?


#2

Without knowing whether you are running different versions of Pressbooks and root themes on dev and production, I can’t really determine what would cause this.


#3

Hi Steel,

Have you contacted Lumen? My understanding is that It’s their plugin - so they might have some ideas.

I don’t have any other comments on the tech side.

BUT the best course of action is for Pressbooks to “officially” support the LTI standard, which would mean that these things are our problem to solve, not yours (or Lumen’s for that matter).

LTI support is "on our roadmap."

This means: "we would like to tackle this once resources are available to do so."

The route to make this happen sooner rather than later is helping shepherd resources for this kind of dev work.

Happy to discuss off-forum if you like :wink:


#4

Something good to try when links aren’t working, in a very general sense: visit /wp-admin/options-permalink.php, click Save. Flushes rewrite rules, which may help pages load if something’s preventing them.


Rollback planning
#5

Yep–I wrote to Bryan and Bracken this morning. I suspect it’s actually connected to how our production site is configured, so if I can’t resolve it, I will be sending a message to our hosting provider soon, but was hoping to try to troubleshoot before I got to that stage, in case it was something easy I could figure out on my own (or advise our hosts).


#6

@ned, the permalinks suggestion appears to have fixed it. Thanks for the tip! For others who might be affected and for future reference, I went in to the direct link Ned shared and changed the setting to ‘Post Name’:


and made a save. It worked thereafter. Strangely, I also checked our dev site where it was already working, and the permalink settings there were still set to the default. Don’t know if the setting chosen makes a difference so much as the flushing/rule rewriting.


#7

One final comment/suggestion, it doesn’t appear to me that the permalinks menu is accessible anywhere in the Pressbooks dashboard (for the network or individual books).


That may be by design and for a good reason, but in this case, if I hadn’t known about the direct URL (thanks to your tip, Ned), it’s unlikely I would have ever been able to resolve this problem. Is there a case to be made for adding a link to the permalinks page back to PB, like it is for core WP? 42 AM


#8

It is deliberately suppressed from the book interface and we have other measures in place to ensure that book permalinks are maintained properly without user intervention. There is a case for it to be available on the root site. I’ll look at restoring this in our new root theme.