Theme update errors

Strange one…

For a reason I haven’t figured out, I stopped getting prompts to update plugins and themes, so I installed GitHub Updater and that seemed to solve the issue with most things. Everything is updating except the following themes: McLuhan, Aldine, and Donham.

When I attempt to update all three themes I get the following message for McLuhan and Aldine only: “Update Failed: The update cannot be installed because we will be unable to copy some files. This is usually due to inconsistent file permissions.” Donham indicates that it has updated, but when I refresh or log out and back in, it has not “taken” and prompts me to update again.

I’ve checked with our server maintainer and he says “The permissions are correct. Without auditing their code I cannot resolve the issue.”

Here are the theme versions I am trying to update from:
Aldine: 1.6.0 --> 1.8.0
McLuhan: 2.8.1 --> 2.10.0
Donham: 1.7.0 --> 2.0.0

Is this a GitHub updater issue? Something else?

UPDATE: When attempting to update a theme directly in GitHub Updater in the Install Theme tab, the following error appears: “Destination folder already exists. /var/www/html/wp-content/themes/pressbooks-aldine/. Theme installation failed.”

UPDATE: Our server admin was able to login as me to the Admin pages and update Aldine and McLuhan. Can’t explain that really.

However, still no Donham. Our admin claims that "The Donham theme is broken. The config is wrong. The version on their server is lying about the version.

After update, the version in the control file reads.

Copyright: 2011-2017 Pressbooks (Book Oven Inc.
Version: 1.7.0
Template: pressbooks-book

So you can see the file was updated
-rw-r–r-- 1 www-data www-data 632 Mar 31 17:18 style.css
But it has the wrong version.
Theme Name: Donham
Theme URI:
Description: This theme is named after Wallace Donham, Dean of Harvard Business School from 1919 to 1942. The Donham theme is a light, modern theme, equally effective for non-fiction and fiction. Body font is Tinos, and Header font is Galdeano. An earlier version of this theme was commissioned by Harvard Business Review Press.
Author: Pressbooks (Book Oven Inc.)
Author URI:
Copyright: 2011-2017 Pressbooks (Book Oven Inc.
Version: 1.7.0
Template: pressbooks-book
GitHub Theme URI: pressbooks/pressbooks-donham

That’s probably an issue on our end. @homanchan I can see that we have a ‘draft’ release for v2.0.0 in GitHub: Related?

It looks like the 1.7.1 release is pointing to 2.0.0. We will address this. Thank you!

1 Like

Did this ever get resolved? We still see the stale “You have version 1.7.0 installed. Update to 2.0.0” WordPress update available.


Just popping in to say that this is still an issue for Donham, and it looks like the same issue is happening with McLuhan 2.11.1

hi @beckej & @figureone can either of you attach a screenshot showing what you’re seeing from the plugins dashboard or wherever else you’re seeing the error message(s) for McLuhan and Donham? We should be able to take a look at this later this week, but I don’t know what you’re seeing exactly because we use different methods for updating plugins and themes in our local, staging, and production environments.

I just tested today and saw the same thing regarding McLuhan 2.11.0 => 2.11.1.

However, I was able to update successfully after refreshing the GitHub Updater plugin cache (Dashboard > Settings > Github Updater > Refresh Cache).

Thanks for checking in @SteelWagstaff!

Ok, thanks. We did release McLuhan 2.11.1 a couple weeks ago (Release McLuhan 2.11.1 · pressbooks/pressbooks-book · GitHub), so that one’s a real release. With the Donham theme I think the problem there is that we accidentally bumped the version in the theme CSS file: pressbooks-donham/style.css at master · pressbooks/pressbooks-donham · GitHub but never released a 2.0 version of the theme, so your site is nagging you to update to a release which it can’t find because it doesn’t exist.

1 Like

Hi Steel,

This is what I am seeing. We are using the Github Updater plugin, and both of these plugins were updated right before I took this screenshot.

We don’t see any error messages or other ill effects, the only symptom we see is that Pressbooks constantly tells us that we need to upgrade this plugin.

Thanks @beckej – the Donham error I understand (it’s a problem we created), but I’m confused as to why you’re not able to update McLuhan, which does have a 2.11.1 version released, tagged, and available via GitHub: Release McLuhan 2.11.1 · pressbooks/pressbooks-book · GitHub. Does the method described by @figureone earlier

I was able to update successfully after refreshing the GitHub Updater plugin cache (Dashboard > Settings > Github Updater > Refresh Cache)

change anything for you with that theme?

@beckej it sounds to me like GitHub Updater is not fetching new metadata from GitHub. GitHub recently changed the format of their Personal Access Tokens which the plugin uses to avoid throttling when querying GitHub for updates. See:

It’s possible that you will need to generate a new token and add it to the plugin at Dashboard > Settings > GitHub Updater > GitHub (tab), and then click Refresh Cache. You should see the list of plugins/themes on that page, and whether their latest information has been fetched from GitHub.

1 Like


Thanks for your help. I did update the cache yesterday before trying to update, and I did it again today. Going to the Github page under settings, I was able to confirm that all my plugins were listed. When I tried again to update it did it fine.

So one down! One to go!

1 Like