The requested URL was not found on this server

As the administrator I added a book and put in the basic info. When I clicked on create book I got a 404
Not Found

The requested URL /a000654493/wp-admin/ was not found on this server.

I am currently configured for sub directories and have no dependencies installed yet (part 3 of the setup instructions)

Oh yes, and email notifications still not working either.

Lot of questions I know. Sorry about that.

This hints that you are not configured correctly.

Without information no one can help you. What webserver are you using? (Apache / Nginx / IIS / … ?).

If you are using Apache then what do your rewreite rules looks like? If not, then rewrite rules won’t work and you will have to translate them to your platform. Did you?


Using Apache on Ubuntu server 18.04 LTS
.htaccess file content is as follows:

BEGIN WordPress

RewriteEngine On RewriteBase / RewriteRule ^index\.php$ - [L]

add a trailing slash to /wp-admin

RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).) $2 [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(.
.php)$ $2 [L]
RewriteRule . index.php [L]

END WordPress

Sorry, we can’t really help with this.

Figured it out myself. You may want to improve the installation documentation.
Things I did :slight_smile:

  1. Made sure to create /var/www/wordpress directory and run chown -R www-data:www-data /var/www/wordpress

  2. In /etc/apace2 sites-enabled created wordpress.conf added this on line 12:
    ServerAdmin webmaster@localhost
    DocumentRoot /var/www/wordpress

    <Directory /var/www/wordpress>
    AllowOverride All
    Order Allow,Deny
    Allow from All

  3. Disabled 000-default.conf in same directory

  4. In /var/www/wordpress addeed to hidden .htaccess file :
    Options +FollowSymLinks

Bingo ! I created my first book.
I suspect the permissions can be locked down a tad more but I will work on that once I have finished installing the dependencies…

Hope this helps someone.

If there are any issues related to the Pressbooks portion of the installation we are happy to add/improve them. It sounds like the trouble you were having was with the initial WordPress Multisite installation, and it is not practical for us to maintain a parallel set of documentation to the WordPress project especially given that WordPress Multisite installation varies from server to server (Apache/Nginx/etc). Glad you got it worked out!

also using xampp

go to C:\xampp\apache\conf
open httpd.conf file

when you see this :
require all denied

replace with this:

DocumentRoot “C:/xampp/htdocs”

<Directory “C:/xampp/htdocs”>
Options Indexes FollowSymLinks Includes ExecCGI
AllowOverride All
Require all granted

Alias /some/url C:/xampp/htdocs/some/dir