Problem with new language nl_NL showing in backend not frontend

I have translated (for the most part I will finish later) the language files for the Dutch language. I have added them to my self hosted Pressbooks install.
The Main site and dashboard are now in Dutch, but the book on the wildcard subdomain that is set to Dutch stays in English. If I switch to German all parts are in German, so the language switching itself is working fine. What am I missing here?!

Screenshot from 2020-05-15 08-41-09|690x388

Main site working fine in Dutch.

Hi @Nienke_Coppens. Dank u! I think you will want to change/set the book language itself in ‘book info’. See https://guide.pressbooks.com/chapter/languages/ for more details. Not sure if you saw, but we maintain localization files for our main open source repositories on Transifex: https://www.transifex.com/pressbooks/public/. Would love your Dutch contributions if you’re willing to share them (we’re at ~86% for Pressbooks itself but would be great to get higher: https://www.transifex.com/pressbooks/pressbooks/)

Thanks for the quick reply.
The strange thing is the book is set to Dutch. If I switch it to German it switches to German, but switched to Dutch it stays English. The strings for all those have been translated I triple checked.

I did all the translating in transifex. Got it to 86% the past couple of days I will finish it soon so you can include in the next release. There are only some longer backend strings left to do. All the main back and frontend stuff has been done.

Hi @Nienke_Coppens, thank you for clarifying and for your language contributions to the project so far! My first thought is that perhaps these strings belong to another component besides Aldine (the network root theme) and core Pressbooks itself. For example, when I look at Pressbook-book, the default book theme, I see that Dutch coverage is still zero. Can you specify which strings you’re expecting to see Dutch translations for but which aren’t appearing so I can take a a closer look? Just a few examples would be helpful.

Also, if you have any suggestions for us about how we can improve the instructions that we give volunteer translators for understanding and contributing to our project, I’d love to hear them. We’re always interested in making this experience easier and less frustrating for people who are volunteering their time and linguistic expertise to help us internationalize and localize our project.

I am not using McLuhan, but using Clarke and I have translated that using poedit locally.
I will translate all the missing parts in transifex related to pressbooks in the next couple of weeks.

The problem is that the top menu for example stays english in the book pages. The same menu on the main page is in Dutch. That suggests a technical problem not a translation problem.
But I will translate McLuhan now (that’s a quick one since I already did clarke) and upload on my pressbooks server to see of it somehow still uses McLuhan.

Hi @Nienke_Coppens Not sure if it will help, but all of our other themes (Clarke, etc) are ‘children’ of McLuhan, which means that they do inherit a lot of elements from it. You may well be right about it being a technical and not a translation problem, however. Can you tell me which ‘top menu’ you are referring to that remains in English? Screenshot and one or two strings should be enough for me to find a reference on my end.

I translated McLuhan on transifex. Downloaded and added the file, but unfortunately no change.

I added the completely translated pressbooks-book(mcluhan), Clarke and Aldine as nl_NL and the mostly translated pressbooks nl_NL file.

Book language admin panel and config file are all set to Dutch.
book-language

The main domain site is in Dutch.

@Nienke_Coppens have you tried changing your user language profile to Dutch as well? See: https://guide.pressbooks.com/chapter/languages/#uilanguage. Did that make any difference?

But the subdomains (books) even though set to Dutch stay English. The strange thing is it does switch if I switch to German for example. I have pretty extensive wordpress experience and have also translated many wordpress plugins to Dutch over the years. I just really don’t get why it is not showing as Dutch.

1 Like

Ok – I think I’m grasping the issue here. To restate:

  1. you’ve produced Dutch language translations (nl_NL) for Pressbooks, Aldine, McLuhan, and Clarke and installed these locally so that they’re available to your installation of Pressbooks.
  2. You’ve set the network language to Dutch, and set Dutch as the language in Book Info.
  3. Most strings are being rendered in Dutch in the admin menu when you visit your root site (hajcoppens.nl), but not when you visit the admin menu for books on your network (i.e. taaltest.hajcoppens.nl). The text you’re most perplexed by specifically is the header nav menu, i.e. “Home | Read | Admin | Sign Out” etc. which is being translated to Dutch on the root site, but not the book subdomains.

Is that an accurate summation? If so, it appears that it may be something on our end, as you suspected. I don’t have any immediate ideas for what’s going on. Today’s a holiday in Montreal, but I’ll bring this up with others on our dev team later in the week when people are back at work.

Good recap. It of course is not just the top menu in the books sites (that one is just most obvious) it is all the strings, like contents, hide all contents, the previous and next buttons read book etc. Only frontend!
Frontend is translated for hajcoppens.nl, not for taaltest.hajcoppens.nl.
Backend is in Dutch in both hajcoppens.nl and taaltes.hajcoppens.nl.

It might be a technical problem on my side, but I have no idea where to look. Everything seems to work fine and without any errors.

1 Like

Can I ask you to try one more thing? Will you clear your browser cache and then – for the book(s) in question – click the diagnostics link at the bottom of the admin page and then regenerate the stylesheet?
Screenshot from 2020-05-19 14-57-35

Tried it, but no change.

Ok. Thanks. If you’re willing, please post the contents of the diagnostics page (system info, etc) here or in a DM and we’ll look into it and see if we can replicate or fix. Thanks for being willing to experiment on this, and sorry about the frustration. I hope we’ll get this solved for you soon!

@Nienke_Coppens are you able to share the contents of your diagnostics page with us? I ask because it will help us in replicating your issue locally.

Sorry about the delay, I had some other obligations to deal with.
Here is the diagnostics page.

System Information

Book Info

Book ID: 6
Book URL: http://taaltest.hajcoppens.nl/
Book Privacy: Public

Browser

Platform: Windows
Browser Name: Firefox
Browser Version: 76.0
User Agent String: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:76.0) Gecko/20100101 Firefox/76.0

WordPress Configuration

Network URL: http://hajcoppens.nl/
Network Type: Subdomain
Version: 5.4.1
Language: nl_NL
WP_ENV: Not set
WP_DEBUG: Disabled
Memory Limit: 64M

Pressbooks Configuration

Version: 5.14.3
Book Theme: Clarke
Book Theme Version: 2.3.3
Root Theme: Aldine
Root Theme Version: 1.8.0

Pressbooks Dependencies

Epubcheck: Installed
Kindlegen: Installed
xmllint: Installed
PrinceXML: Installed
Saxon-HE: Installed

Must-Use Plugins

hm-autoloader.php: n/a

Network Active Plugins

mPDF for Pressbooks: 3.3.1
Pressbooks: 5.14.3

Book Active Plugins

mPDF for Pressbooks: 3.3.1
Pressbooks: 5.14.3

Inactive Plugins

Akismet Anti-Spam: 4.1.5

Server Configuration

PHP Version: 7.4.5
MySQL Version: 5.5.5
Webserver Info: nginx/1.14.0

PHP Configuration

Safe Mode: Disabled
Memory Limit: 256M
Upload Max Size: 2M
Post Max Size: 8M
Upload Max Filesize: 2M
Time Limit: 30
Max Input Vars: 1000
URL-aware fopen: On (1)
Display Errors: N/A

PHP Extensions

OPcache: Zend
XDebug: Disabled
cURL: Supported
cURL Version: 7.58.0
imagick: Installed
xsl: Installed

Sorry I had to deal with some issues. My VPS was suddenly removed so I had to set up everything again. I am still having some technical issues with the installation, but I see the problem is solved now that you have added the Dutch files to the package. Everything is perfectly in Dutch on all front and backend pages.

Thank you so much.