Plugin could not be activated because it triggered a fatal error

So, I’m pretty stumped. I’ve tried installing Pressbooks on two separate servers run by two different host providers. No matter what I do, I end up with an error when I try to activate the plug in. I’ve even tried different versions of pressbooks just to make sure that’s not the problem. Here’s my most recent attempt:

Fatal error: Uncaught Error: Call to undefined function update_blog_option() in /chroot/home/dzfrbwbpjjjvcytl/pinkslothbooks.com/html/press/wp-content/plugins/pressbooks/compatibility.php:103 Stack trace: #0 /chroot/home/dzfrbwbpjjjvcytl/pinkslothbooks.com/html/press/wp-includes/class-wp-hook.php(287): pb_register_activation_hook(’’) #1 /chroot/home/dzfrbwbpjjjvcytl/pinkslothbooks.com/html/press/wp-includes/class-wp-hook.php(311): WP_Hook->apply_filters(’’, Array) #2 /chroot/home/dzfrbwbpjjjvcytl/pinkslothbooks.com/html/press/wp-includes/plugin.php(484): WP_Hook->do_action(Array) #3 /chroot/home/dzfrbwbpjjjvcytl/pinkslothbooks.com/html/press/wp-admin/plugins.php(193): do_action(‘activate_pressb…’) #4 {main} thrown in /chroot/home/dzfrbwbpjjjvcytl/pinkslothbooks.com/html/press/wp-content/plugins/pressbooks/compatibility.php on line 103

Admittedly, my Word Press skills are somewhat basic, so I really don’t have any idea what to do here. When I did talk to one of the hosting providers, they just said pressbooks was incompatible and had no other information. For some reason, I don’t think that’s what’s going on, but I can’t say for sure. The version I uploaded here was 5.18.1.

Thanks

Jason

@Jason_Wrench, two starting questions: 1) did you follow the instructions described here: https://docs.pressbooks.org/installation/#part-2-pressbooks? And 2) is your server running PHP 7.3 (https://github.com/pressbooks/pressbooks)