mPDF options page

By actiavting mPDF plugin in one site, I get an Empty settings page for the site where I have activate the plugin.

If I do activate in network level, it works, but maybe some default settings, at least, for Page Size, Left margin and Right margin helps for doomies.

System Information

Book Info

Book ID: 8
Book URL:
Book Privacy: Public


Platform: OS X
Browser Name: Firefox
Browser Version: 54.0
User Agent String: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:54.0) Gecko/20100101 Firefox/54.0

WordPress Configuration

Network URL:
Network Type: Subdirectory
Version: 4.8
Language: en_US
WP_ENV: Not set
WP_DEBUG: Enabled
Memory Limit: 64M

Pressbooks Configuration

Version: 4.0.1
Book Theme: Luther
Book Theme Version: 1.9.2
Root Theme: Pressbooks Publisher
Root Theme Version: 3.1.1

Pressbooks Dependencies

Epubcheck: Not Installed
Kindlegen: Installed
xmllint: Installed
PrinceXML: Not Installed
Saxon-HE: Installed

Must-Use Plugins

hm-autoloader.php: n/a

Network Active Plugins

Pressbooks: 4.0.1
Wordfence Security: 6.3.12

Book Active Plugins

Pressbooks mPDF: 1.7.0

Inactive Plugins

Akismet Anti-Spam: 3.3.3
Hello Dolly: 1.6
Pressbooks Textbook:

Server Configuration

PHP Version: 7.0.21
MySQL Version: 5.5.53
Webserver Info: Apache

PHP Configuration

Safe Mode: Disabled
Memory Limit: 256M
Upload Max Size: 2M
Post Max Size: 8M
Upload Max Filesize: 2M
Time Limit: 30
Max Input Vars: 1000
URL-aware fopen: On (1)
Display Errors: On (1)

PHP Extensions

cURL: Supported
cURL Version: 7.35.0
imagick: Installed
xsl: Installed

Pressbooks mPDF 2.0 is out. Any reason you haven’t updated? Does it fix these issues for you?

Thre is not an update warming in my installation. I´’ll do manually

it works. thanks Ned. I do not know why i did not receive the update warming.

It’s possible that the new version did not get tagged correctly on FYI @brad.

I haven’t changed anything or done any recent updates, but I notice a difference in behaviour today and yesterday than earlier on in the week. I too was not seeing any update notifications, but without intervention on my part now that’s changed.

1 Like