Installation Error - "Hmm. We’re having trouble finding that site."

Having trouble installing Pressbooks.

I use HostGator for hosting. From cPanel used their QuickInstall software to install a fresh installation of WordPress. Followed everything step-by-step from the instructions here:

Everything seems OK until I get to step 13. I filled in the webbook address (which appears to have been created) & Book Title, but when I hit Create Book I get the error message “Hmm. We’re having trouble finding that site.” Under My Catalog, I see the book. However, when I try to go to it’s dashboard I get the same error message.

What should I do?

Have you installed the default theme ?
and made sure that theme folder name is correct in FTP for Step 3 ?

Yes to both. Installed it to the /path/to/your/site/wp-content/themes/* as per the instructions. Only pressbooks-publisher had version numbers after the name and needed to be corrected.

I found that if I install via FTP I got different permissions than installing within WordPress.
My folder permissions (from WP install) look like this:

In cPanel File Manager, permissions are shown as numbers. Folders as 775 (same as yours it appears) and 664 for individual files.

I’ll try to track down a FTP program tomorrow and reinstall those files with it to see if it makes a difference.

I now install everything through WordPress Themes/Plugins add new, to prevent permission errors when updating in WP.

Assuming that your initial multisite install is working with latest PHP… and you can see the network dashboard… and create sites before the PB install, then I would try installing PB plugins and themes from within WP. Unfortunately I don’t use HostGator.

Did you update your .htaccess file properly after creating a network (see step 5)? It should look like one of these two options:

If you can access the main site but not any created books that’s probably the issue.

Hmm, what I pasted and what showed is a little different. I’ll upload an image of what it says.

Is your network set up as a subdomain or subdirectory install?

A sample live PB multisite .htaccess by subdirectory install in root WP folder:

RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]

# add a trailing slash to /wp-admin
RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
RewriteRule . index.php [L]

Now I see there’s a htaccess file both in root and in the public_html folder where the website is. The instructions weren’t clear which to edit. I edited the one in the public_html folder. Was I supposed to edit the one in root?

The account does have a subdomain with a different url, but for the pressbook install I’m using the main url for the hosting service.

You should have setup WordPress multisite when installing Pressbooks. When doing so you should have chosen whether your books would be subdomains or subdirectories. An easy way to tell is look at the address of the book you tried to create: is it or If the former, you are using subdomains. If the latter, you are using subdirectories.

Now, for the .htaccess file, it should be the one that’s in the same directory as your wp-config.php file. And it should have the appropriate contents based on the link I shared above.

Thanks, I got a bit confused with terminology. I only deal with the backend stuff of websites about once a year.

I set up the WordPress multisite to use subdomains, though now I wish I did it as subdirectories. Didn’t really understand the choice at the time. The Pressbooks instructions don’t say much about that stage.

The public_html folder is the one with the wp-config.php file, so I did edit the correct htaccess file.

Tried using the above example htaccess, but everything looks exactly the same.

So, if you set up WordPress multisite to use subdomains then you need to make sure your DNS is configured to allow wildcard subdomains by adding an A record pointing * to your server’s IP address. I’ll bet that is the reason your book isn’t loading. Let me know if that works.

Let me know if you had any luck with my instructions in the last post.

I will. I don’t know how to do what you suggested, so I have to look that up first. Been too busy to do so the last few days.

See here for instructions with your host:

In general, if you just want to try out Pressbooks, I’d encourage you to set up a free account on our hosted service, It’s way less hassle than setting up your own network.

HI Ned, I am having the same problem, I tried your fix with the A record, but still getting the same issue. Any other thoughts?

Hi Erad67, did you fix your problem? Could you share how please?