GITHUB-UPDATER for PB


#1

Github-updater 7.2.0 works but 7.3.0 and 7.3.1 give a white screen of death when FTP installed and network activated. Never had any issues before 7.3 in WP plugin updating.

Attempting to use WP update plugin function caused the following error:
Enabling Maintenance mode…
Updating Plugin GitHub Updater (1/1)

Downloading update from https://api.github.com/repos/afragen/github-updater/zipball/7.3.1…
Unpacking the update…
Installing the latest version…
Removing the old version of the plugin…
Plugin update failed.

An error occurred while updating GitHub Updater: The update cannot be installed because we will be unable to copy some files. This is usually due to inconsistent file permissions. vendor, readme.txt, js, src, assets, uninstall.php, css, LICENSE, languages, README.md, CHANGES.md, mu, github-updater.php, vendor/persist-admin-notices-dismissal, vendor/parsedown, vendor/class-parser.php, js/ghu_install.js, src/Autoloader.php, src/GitHub_Updater, assets/GitHub_Updater_logo_small.png, css/github-updater.css, languages/github-updater.pot, mu/ghu-loader.php, vendor/persist-admin-notices-dismissal/README.md, vendor/persist-admin-notices-dismissal/dismiss-notice.js, vendor/persist-admin-notices-dismissal/persist-admin-notices-dismissal.php, vendor/parsedown/Parsedown.php, vendor/parsedown/README.md, vendor/parsedown/LICENSE.txt, src/GitHub_Updater/GitHub_API.php, src/GitHub_Updater/API.php, src/GitHub_Updater/Additions.php, src/GitHub_Updater/GHU_Upgrade.php, src/GitHub_Updater/Readme_Parser.php, src/GitHub_Updater/Bitbucket_Server_API.php, src/GitHub_Updater/Branch.php, src/GitHub_Updater/Language_Pack_API.php, src/GitHub_Updater/Language_Pack.php, src/GitHub_Updater/Base.php, src/GitHub_Updater/Plugin.php, src/GitHub_Updater/Messages.php, src/GitHub_Updater/Settings.php, src/GitHub_Updater/CLI_Integration.php, src/GitHub_Updater/Rest_Update.php, src/GitHub_Updater/Theme.php, src/GitHub_Updater/API_Interface.php, src/GitHub_Updater/Install.php, src/GitHub_Updater/Bitbucket_API.php, src/GitHub_Updater/Basic_Auth_Loader.php, src/GitHub_Updater/GitLab_API.php, src/GitHub_Updater/CLI.php, src/GitHub_Updater/Rest_Upgrader_Skin.php, src/GitHub_Updater/Singleton.php

Disabling Maintenance mode…


#2

Please don’t post support questions for third-party plugins here.


#3