Book Dashboard error message

After upgrade to PB 5.9.1 and McLuhan 2.8.9, Aldine 1.6.4
navigating to a book > selected book dashboard > message is:

The site is experiencing technical difficulties. Please check your site admin email inbox for instructions.

Noteworthy is that Network admin dashboard is functioning correctly.

The source of the message error that affects all books on the site is due to H5P 1.14.1
Network deactivating H5P restores dashboards of all books.

Someone has reported the same error 2 weeks ago on the H5P support forum on

I’m getting the same error:

Warning : require_once(/var/www/html/wp-content/plugins/h5p/h5p-php-library/h5p.classes.php): failed to open stream: No such file or directory in /var/www/html/wp-content/plugins/h5p/autoloader.php on line 49

Fatal error : require_once(): Failed opening required ‘/var/www/html/wp-content/plugins/h5p/h5p-php-library/h5p.classes.php’ (include_path=’.:/usr/share/php’) in /var/www/html/wp-content/plugins/h5p/autoloader.php on line 49

The site is experiencing technical difficulties. Please check your site admin email inbox for instructions.

Hi sswettenham,

I was able to fix this issue. This is a bug with the version of H5P that is uploaded to wordpress and is installed when you click upgrade.

From what I can understand, H5P has a folder inside it called /h5p-php-library

This folder is its own github folder/project that is only linked to from the primary H5P Wordpress Github. When they created the most recent Wordpress version that you can upgrade to, they forgot to include the h5p-php-library folder. The developers probably didn’t even notice because they probably upgrade from the command line using git, not the easy way from the web interface novices like me use.

So to fix it:

  1. Go to and download the most recent version of the h5p-php-library folder.
  2. Upload that folder to your h5p plugin folder. (You will have an empty folder right where it will need to go)

When I followed those steps it solved all my problems. I will also try to fix the github ticket to draw their attention to the issue.

Edit: You will have to go through the same steps for the h5p-editor-php-library folder.

1 Like

I can confirm that adding the library fixed the issue.

It appears that all WP H5P releases ( ) have empty library folders.

I have also added the editor library folder from
with no issue.


Looking into this further…

I wondered if the problems we all had was due to the github updater plugin. When I downloaded the folder directly from it had all the required folders.

Does anyone who has more experience with the github updater plugin know if this makes sense as a problem. Is there a way to deactivate the github updater plugin just for H5P to force it to use the version?

It’s probably GitHub updater.

The package it is downloading from GitHub don’t contain the submodule folders. Since H5P isn’t actually packaging anything, those files are simply automatically generated by GitHub when a tag is made, this is entirely normal.